using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc";
string input = @"hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match
hello23abc ==> match
helloaabc ==> match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}