use strict;
my $str = 'hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match
hello23abc ==> match
helloaabc ==> match';
my $regex = qr/(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}