package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc`)
var str = `hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match
hello23abc ==> match
helloaabc ==> match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}