$re = '/(?:hello.*?123.*?abc)(*SKIP)(*F)|hello.*?abc/m';
$str = 'hello123abc ==> no match
helloa123abc ==> no match
hello123aabc ==> no match
hello1abc ==> match
hello23abc ==> match
helloaabc ==> match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);