# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B"ORDER BY" \B/$1 $2/gm;t' <<< "ORDER BY Security, 3, Portfolio"