import re
regex = re.compile(r"\B\"ORDER BY\" \B", flags=re.MULTILINE)
test_str = "ORDER BY Security, 3, Portfolio"
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)