#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\/]+?)([-_0-9]*?)(\.[^\/]*)?\.js"
Local $sString = "http://ds.serving-sys.com/CurstingRes//CustomScripts/mmm_interbillage_052016.js?target=.position_pub.top.banniere&width=1280&height=772"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")