// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\/]+?)([-_0-9]*?)(\.[^\/]*)?\.js").unwrap();
let string = "http://ds.serving-sys.com/CurstingRes//CustomScripts/mmm_interbillage_052016.js?target=.position_pub.top.banniere&width=1280&height=772";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}