$re = '/([^\/]+?)([-_0-9]*?)(\.[^\/]*)?\.js/';
$str = 'http://ds.serving-sys.com/CurstingRes//CustomScripts/mmm_interbillage_052016.js?target=.position_pub.top.banniere&width=1280&height=772';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);