const regex = /([^\/]+?)([-_0-9]*?)(\.[^\/]*)?\.js/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\/]+?)([-_0-9]*?)(\\.[^\\\/]*)?\\.js', '')
const str = `http://ds.serving-sys.com/CurstingRes//CustomScripts/mmm_interbillage_052016.js?target=.position_pub.top.banniere&width=1280&height=772`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}