#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[+-]?\d+([,.]\d+)?$"
Local $sString = "0.00" & @CRLF & _
"1,0.00" & @CRLF & _
"100.00" & @CRLF & _
"1,000.00" & @CRLF & _
"1,000,000,000.00" & @CRLF & _
"100,000.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")