package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[+-]?\d+([,.]\d+)?$`)
var str = `0.00
1,0.00
100.00
1,000.00
1,000,000,000.00
100,000.00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}