re = /^[+-]?\d+([,.]\d+)?$/
str = '0.00
1,0.00
100.00
1,000.00
1,000,000,000.00
100,000.00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end