$re = '/^[+-]?\d+([,.]\d+)?$/';
$str = '0.00
1,0.00
100.00
1,000.00
1,000,000,000.00
100,000.00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);