#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^0-9\n]*(?:((?|[12](?=(?>.*\n)*([^#]+))|3(?=(?>.*\n)*[^#]*#([^#]+))|[45](?=(?>.*\n)*(?:[^#]*#){2}([^#]+)))\d+).*|.*\z)"
Local $sString = "Blah 12345 Blah" & @CRLF & _
"Blah 22345 Blah" & @CRLF & _
"Blah 32345 Blah" & @CRLF & _
"Blah 42345 Blah" & @CRLF & _
"Blah 52345 Blah" & @CRLF & _
"AAA#BBB#XYZ"
Local $sSubst = "$2$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)