use strict;
my $str = 'Blah 12345 Blah
Blah 22345 Blah
Blah 32345 Blah
Blah 42345 Blah
Blah 52345 Blah
AAA#BBB#XYZ';
my $regex = qr/^[^0-9\n]*(?:((?|[12](?=(?>.*\n)*([^#]+))|3(?=(?>.*\n)*[^#]*#([^#]+))|[45](?=(?>.*\n)*(?:[^#]*#){2}([^#]+)))\d+).*|.*\z)/mp;
my $subst = '$2$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";