import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^0-9\\n]*(?:((?|[12](?=(?>.*\\n)*([^#]+))|3(?=(?>.*\\n)*[^#]*#([^#]+))|[45](?=(?>.*\\n)*(?:[^#]*#){2}([^#]+)))\\d+).*|.*\\z)";
final String string = "Blah 12345 Blah\n"
+ "Blah 22345 Blah\n"
+ "Blah 32345 Blah\n"
+ "Blah 42345 Blah\n"
+ "Blah 52345 Blah\n"
+ "AAA#BBB#XYZ";
final String subst = "$2$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}