import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "span var1=\"(.*?)\"(?:.*)var2=\"(.*?)\"(?:.*)var3=\"(.*?)\"(?:.*)\\/span";
final String string = "<span var1=\"abc\" some random thing var2=\"cde\" another random stuf??><::\" var3=\"efg\"></span><span var1=\"abc\" some random thing var2=\"cde\" another random stuf??><::\" var3=\"efg\"></span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}