re = /span var1="(.*?)"(?:.*)var2="(.*?)"(?:.*)var3="(.*?)"(?:.*)\/span/
str = '<span var1="abc" some random thing var2="cde" another random stuf??><::" var3="efg"></span><span var1="abc" some random thing var2="cde" another random stuf??><::" var3="efg"></span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end