// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"span var1="(.*?)"(?:.*)var2="(.*?)"(?:.*)var3="(.*?)"(?:.*)\/span"#).unwrap();
let string = "<span var1=\"abc\" some random thing var2=\"cde\" another random stuf??><::\" var3=\"efg\"></span><span var1=\"abc\" some random thing var2=\"cde\" another random stuf??><::\" var3=\"efg\"></span>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}