import Foundation
let pattern = #"span var1="(.*?)"(?:.*)var2="(.*?)"(?:.*)var3="(.*?)"(?:.*)\/span"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<span var1="abc" some random thing var2="cde" another random stuf??><::" var3="efg"></span><span var1="abc" some random thing var2="cde" another random stuf??><::" var3="efg"></span>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}