#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}"
Local $sString = "01.01.2009" & @CRLF & _
"01-Jan-2009" & @CRLF & _
"15.15.2009" & @CRLF & _
"05.12.2009" & @CRLF & _
"32.01.2009" & @CRLF & _
"30.01.2019" & @CRLF & _
"35.01.2019"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")