import re
regex = re.compile(r"^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}", flags=re.MULTILINE)
test_str = ("01.01.2009\n"
"01-Jan-2009\n"
"15.15.2009\n"
"05.12.2009\n"
"32.01.2009\n"
"30.01.2019\n"
"35.01.2019")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")