#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([a-z]{4}tion|[a-z]{6}able)\b"
Local $sString = "bortion" & @CRLF & _
"abortion" & @CRLF & _
"abortioq" & @CRLF & _
"mportable" & @CRLF & _
"importable" & @CRLF & _
"importablq"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")