$re = '/\b([a-z]{4}tion|[a-z]{6}able)\b/m';
$str = 'bortion
abortion
abortioq
mportable
importable
importablq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);