import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>)\\s*|\\s*(?=<a)";
final String string = " <a rel=\"nofollow noopener\" style=\"display:inline; text-decoration: none;\" href=\"\">\n"
+ " <img border=\"0\" class=\"full\" height=\"auto\" width=\"300\" alt=\"\" src=\"http://via.placeholder.com/600x338\">\n"
+ " </a>\n"
+ " <a rel=\"nofollow noopener\" style=\"display:inline; text-decoration: none;\" href=\"\">\n"
+ " <img border=\"0\" class=\"full\" height=\"auto\" width=\"300\" alt=\"\" src=\"http://via.placeholder.com/600x338\">\n"
+ " </a>\n"
+ " <a rel=\"nofollow noopener\" style=\"display:inline; text-decoration: none;\" href=\"\">\n"
+ " <img border=\"0\" class=\"full\" height=\"auto\" width=\"300\" alt=\"\" src=\"http://via.placeholder.com/600x338\">\n"
+ " </a>\n"
+ " <a rel=\"nofollow noopener\" style=\"display:inline; text-decoration: none;\" href=\"\">\n"
+ " <img border=\"0\" class=\"full\" height=\"auto\" width=\"300\" alt=\"\" src=\"http://via.placeholder.com/600x338\">\n"
+ " </a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}