re = /(?<=>)\s*|\s*(?=<a)/m
str = ' <a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result