const regex = /(?<=>)\s*|\s*(?=<a)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>)\\s*|\\s*(?=<a)', 'gm')
const str = ` <a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);