$re = '/(?<=>)\s*|\s*(?=<a)/m';
$str = ' <a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>
<a rel="nofollow noopener" style="display:inline; text-decoration: none;" href="">
<img border="0" class="full" height="auto" width="300" alt="" src="http://via.placeholder.com/600x338">
</a>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;