package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(youtube\.com|youtu\.be)`)
var str = `<iframe src="youtube.com/abc"></iframe>
<iframe src="youtu.be/abc"></iframe>
<iframe src="test.com/abc"></iframe>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}