$re = '/(youtube\.com|youtu\.be)/i';
$str = '<iframe src="youtube.com/abc"></iframe>
<iframe src="youtu.be/abc"></iframe>
<iframe src="test.com/abc"></iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);