// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(youtube\.com|youtu\.be)").unwrap();
let string = "<iframe src=\"youtube.com/abc\"></iframe>
<iframe src=\"youtu.be/abc\"></iframe>
<iframe src=\"test.com/abc\"></iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}