re = /(youtube\.com|youtu\.be)/i
str = '<iframe src="youtube.com/abc"></iframe>
<iframe src="youtu.be/abc"></iframe>
<iframe src="test.com/abc"></iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end