using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[01][0-9]|(?:2[0-3])):[0-5][0-9])";
string input = @"00:00
01:30
1:30
29:00
1345
13:45
17:15
24:55
23:59
(^((0[0-9]|1[0-9]|2[0-3]|[0-2]\n?)$)|(^(2[0-3]\d?)):[0-5]?\d?$)|(^(2[0-3]|[01]\d):[0-5]?\d?$)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}