use strict;
my $str = '00:00
01:30
1:30
29:00
1345
13:45
17:15
24:55
23:59
(^((0[0-9]|1[0-9]|2[0-3]|[0-2]\\n?)$)|(^(2[0-3]\\d?)):[0-5]?\\d?$)|(^(2[0-3]|[01]\\d):[0-5]?\\d?$)';
my $regex = qr~((?:[01][0-9]|(?:2[0-3])):[0-5][0-9])~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}