const regex = new RegExp('((?:[01][0-9]|(?:2[0-3])):[0-5][0-9])', 'g')
const str = `00:00
01:30
1:30
29:00
1345
13:45
17:15
24:55
23:59
(^((0[0-9]|1[0-9]|2[0-3]|[0-2]\\n?)\$)|(^(2[0-3]\\d?)):[0-5]?\\d?\$)|(^(2[0-3]|[01]\\d):[0-5]?\\d?\$)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}