import re
regex = re.compile(r"((?:[01][0-9]|(?:2[0-3])):[0-5][0-9])")
test_str = ("00:00\n"
"01:30\n"
"1:30\n"
"29:00\n"
"1345\n"
"13:45\n"
"17:15\n"
"24:55\n"
"23:59\n\n\n\n\n\n"
"(^((0[0-9]|1[0-9]|2[0-3]|[0-2]\\n?)$)|(^(2[0-3]\\d?)):[0-5]?\\d?$)|(^(2[0-3]|[01]\\d):[0-5]?\\d?$)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")