const regex = /rex mode=sed field=Referer "(action)\"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('rex mode=sed field=Referer "(action)\\"', '')
const str = `https://isc.nwservicecenter.com/iApp/isc/app/pens/pensAccountDetails.action?basho.menuNodeId=19131`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}