re = /rex mode=sed field=Referer "(action)\"/
str = 'https://isc.nwservicecenter.com/iApp/isc/app/pens/pensAccountDetails.action?basho.menuNodeId=19131'
# Print the match result
str.match(re) do |match|
puts match.to_s
end