$re = '/rex mode=sed field=Referer "(action)\"/';
$str = 'https://isc.nwservicecenter.com/iApp/isc/app/pens/pensAccountDetails.action?basho.menuNodeId=19131';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);