const regex = new RegExp('\\(\\*(?:(?!\\(\\*|\\*\\)).)*?\\*\\)', 'gs')
const str = `1. (*comment*)
some code that should not be matched
2. (****comment****)
some code that should not be matched
3. (*comment (*comment inside comment*) comment*)
some code that should not be matched
4. (**) some code that should not be matched (***)
5. (*multi-
line-
comment*) some code that should not be matched
6. (*comment (with parentheses)*)
some code that should not be matched
7. some code that (*comment*) should (not) be matched (*comment*)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}