import re
regex = re.compile(r"\(\*(?:(?!\(\*|\*\)).)*?\*\)", flags=re.DOTALL)
test_str = ("1. (*comment*)\n"
" some code that should not be matched\n\n"
"2. (****comment****)\n"
" some code that should not be matched\n\n"
"3. (*comment (*comment inside comment*) comment*)\n"
" some code that should not be matched\n\n"
"4. (**) some code that should not be matched (***)\n\n"
"5. (*multi-\n"
" line-\n"
" comment*) some code that should not be matched\n\n"
"6. (*comment (with parentheses)*)\n"
" some code that should not be matched\n\n"
"7. some code that (*comment*) should (not) be matched (*comment*)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")