using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^}]*}|[^{}]+";
string substitution = @"";
string input = @"abc{d}efg{hi}{jk}lm{n}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}