package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi){[^}]*}|[^{}]+`)
var str = `abc{d}efg{hi}{jk}lm{n}`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}