use strict;
my $str = 'abc{d}efg{hi}{jk}lm{n}';
my $regex = qr/{[^}]*}|[^{}]+/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";