$re = '/{[^}]*}|[^{}]+/mi';
$str = 'abc{d}efg{hi}{jk}lm{n}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;