package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:::f{4,6}:)?(?P<host>\S+).* ("POST \/ HTTP\/1.1" 301 185)`)
var str = `47.251.13.59 - - [25/Dec/2024:17:10:23 +0200] "POST / HTTP/1.1" 301 185 "-" "Go-http-client/1.1" "-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}