use strict;
my $str = '47.251.13.59 - - [25/Dec/2024:17:10:23 +0200] "POST / HTTP/1.1" 301 185 "-" "Go-http-client/1.1" "-"';
my $regex = qr/^(?:::f{4,6}:)?(?P<host>\S+).* ("POST \/ HTTP\/1.1" 301 185)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}