import Foundation
let pattern = #"^(?:::f{4,6}:)?(?P<host>\S+).* ("POST \/ HTTP\/1.1" 301 185)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"47.251.13.59 - - [25/Dec/2024:17:10:23 +0200] "POST / HTTP/1.1" 301 185 "-" "Go-http-client/1.1" "-""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)