$re = '/^(?:::f{4,6}:)?(?P<host>\S+).* ("POST \/ HTTP\/1.1" 301 185)/';
$str = '47.251.13.59 - - [25/Dec/2024:17:10:23 +0200] "POST / HTTP/1.1" 301 185 "-" "Go-http-client/1.1" "-"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);